Categorías
Momentos Geek

TL-WR841N v9 con OpenWRT

Estos días atrás he estado echando un vistazo al mercado de routers con idea de comprar uno al que se le pudiera cambiar el firmware por uno de estos supervitaminados como DD-WRT, OpenWRT, etc… Como buena parte de la gente que usa estos firmwares lo que quería es usarlo como repetidor wifi, ya que me saldría mucho más barato y con mejores prestaciones (y más funciones).

La verdad es que casi todo el mundo habla del firmware DD-WRT como si fuera la mejor opción, pero también los hay que opinan lo contrario y se inclinan por OpenWRT. En la práctica lo que sí que he sacado en claro es que los routers con soporte de DD-WRT suelen ser más caros que los OpenWRT, o dicho de otro modo, OpenWRT da soporte a routers más económicos que DD-WRT no suele soportar.

TL-WR841N
Imagen del TL-WR841N

Como cambiar el firmware al router es una operación delicada que puede terminar dejando el router como un bonito pisa papeles si algo sale mal… Yo me he decantado por comprar el router más económico que he encontrado con soporte para OpenWRT, que ha sido el que da título a este artículo, el TP-Link TL-WR841N. Lo he comprado en Amazon.es por 16,95€ aunque su precio habitual es de 29,99€, así que me salido tirado de precio 🙂

La verdad es que los comentarios de la mayoría de compradores no daban muy buenas expectativas de que fuera posible ponerle OpenWRT si te enviaban un TL-WR841N con la placa base v9, pero por el precio que me costaba estaba dispuesto a correr el riesgo 😉

La buena noticia es que, como diría un grupo de manifestantes al Sr. Rajoy, sí se puede (frase de moda en España). Se puede poner el firmware OpenWRT a un TL-WR841N v9, pero no es tan sencillo como podría ser con otros modelos, porque hay que instalar el entorno de configuración web desde consola de comandos.

Aunque en la wiki oficial de OpenWRT para el TL-WR841ND (la nomenclatura acabada en D corresponde a otro modelo, pero es idéntico salvo que el D tiene las antenas extraibles), dice a día de hoy que las versiones probadas y compatibles son una trunk o un snapshot concreto, y en los pasos de instalación te remite a la trunk (actual). Yo probé con la trunk y no funcionaba el escaneo de redes wifi desde el router, así que la versión que yo he usado y que funciona perfectamente es la Barrier Breaker 14.07-RC2, que os dejo subida a Mega por si deja de estar disponible en el servidor oficial.